Import-Module : 进程应具有提升的状态才能访问 IIS 配置数据


某同事尝试导入PowerShell的IIS管理组件WebAdministration,遇到了错误:

PS> Import-Module WebAdministration
Import-Module : Process should have elevated status to access IIS configuration data.
At line:1 char:1
+ Import-Module WebAdministration
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (:) [Import-Module], InvalidOperationException
    + FullyQualifiedErrorId : Module_ImportModuleError,Microsoft.PowerShell.Commands.ImportModuleCommand

其实就是需要管理员权限而已,以管理员权限重新打开控制台即可。

但是这里我要稍微客观的批评一下给WebAdministration组件做本地化的哥们了。上面的错误外国人能不能一眼看懂,我不知道。但是你给中文翻译过来的本地化我实在有点受不了啊。

PS> Import-Module WebAdministration
Import-Module : 进程应具有提升的状态才能访问 IIS 配置数据。
所在位置 行:1 字符: 1
+ Import-Module WebAdministration
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (:) [Import-Module], InvalidOperationException
    + FullyQualifiedErrorId : Module_ImportModuleError,Microsoft.PowerShell.Commands.ImportModuleCommand
×用微信扫描并分享
本文链接: https://www.pstips.net/process-should-have-elevated-status-to-access-iis-configuration-data.html
请尊重原作者和编辑的辛勤劳动,欢迎转载,并注明出处!

关于 Mooser Lee

我是一个Powershell的爱好者,创建了PowerShell中文博客,热衷于Powershell技术的搜集和分享。本站部分内容来源于互联网,不足之处敬请谅解,并欢迎您批评指正。

发表评论

电子邮件地址不会被公开。 必填项已用*标注