Powershell需要管理员权限 1


适用于4.0及以上版本
假设一个脚本需要管理员权限,只需要简单的加上 #”需求”就可以满足这个必须条件:

#requires -version 4.0
#requires –runasadministrator


'I am Admin!' 

现在如果脚本没有管理员权限,它将提示你为什么不能运行。

对于低于4.0版本Powershell,脚本仍然会执行,但是发生权限问题则会出错。
原文地址:Requiring Administrator Privileges

×用微信扫描并分享
本文链接: https://www.pstips.net/requiring-administrator-privileges.html
请尊重原作者和编辑的辛勤劳动,欢迎转载,并注明出处!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

一条评论 “Powershell需要管理员权限